beta

Gridsomeで「require() of ES modules is not supported」の対処方法

Gridsomeで「require() of ES modules is not supported」というエラーが出て、ビルドが出来なくなった時の対処方法をまとめました。

公開日:2021年2月19日

distを削除、node_modulesを再インストール

まずは出力先である「dist」ディレクトリと「node_modules」を削除します。

rm -rf dist node_modules package-lock.json

削除できたら、環境変数を追加します。

export VUE_CLI_BABEL_TRANSPILE_MODULES=true

ここまで設定ができたら、ターミナルを開き直します。

新しいターミナルで、プロジェクトルートに入って、node_modulesをインストールします。

npm install

or

yarn install

ここまでやれば、gridsome buildで「require() of ES modules is not supported」というエラーが出ずにビルドできるようになったはずです。

それでも解決しなかった場合は?

この方法でも解決しなかった場合は、「gridsome create」で新しくプロジェクトを作成して、「src」ディレクトリの中身を、元々のプロジェクトの中身からコピーするのが良いかと思います。


Gridsomeで「require() of ES modules is not supported」の対処方法でした。

面倒ではありますが、Gridsomeは静的サイトジェネレータなのでビルドできなければ公開できないので、仕方ありませんね。

Author

Koji Kadoma
Member of codit.work

新着ノート

新着コード